You are in: JCT > Support

Logged in as Guest: login / register

Frequently Asked Questions (FAQs)

This page contain answers to more questions people often ask about our software. If you have a question which is not covered here please do not hesitate to contact us.

LinSig Version 3



LinSig Version 2



TranEd Version 2



FlowRound



LinSig Version 3 Answers


L3.01 Can I open LinSig V2 files in LinSig V3 ?

Yes, LinSig V2 (and LinSig V1) files can be opened in LinSig V3. As LinSig V3 is lane based and previous versions of LinSig are Link based (a Link being a grouping of Lanes) some differences in model structure may occur. LinSig V3 will try and resolve these wherever possible but in some cases, for example a LinSig V2 Link with two Lanes, LinSig V3 cannot automatically restructure the model without further user input. This is to avoid LinSig making arbitrary assumptions which may or may not be correct.

To open a LinSig V2 in LinSig V3 open the file using the normal 'File...Open' menu. LinSig V3 will import the LinSig V2 model but will display any Lane structures which cannot be unambiguously restructured with a 'best guess' structure and highlighted in orange. If the best guess Lane structure is acceptable all that is required is to right mouse click on the orange Lanes and choose 'Accept Lane Structure' from the pop-up menu. Usually additional Lane connectors will also need to be added at this stage for any new Lanes created as part of LinSig automatic Link restructuring. If the 'best guess' Lane structure is not acceptable orange Lanes can be edited or deleted to create an acceptable Lane structure before choosing 'Accept Lane Structure' from the pop-up menu.

In some situations previous versions of LinSig could create Link/Lane structures which cannot currently be directly modelled using LinSig V3 Lane based modelling. The most common situation is a long Lane containing 2 or more short Lanes which is not allowed in LinSig V3 (this is described in more detail in the User Guide.) After importing a LinSig V2 file any such illegal Lane structures will be shown in red. Lanes should be deleted or edited to make them compatible with LinSig V3 before the Lane structure can be accepted into LinSig V3. Note that many of these restrictions apply only to unusual situations which could only be modelled approximately in LinSig V2. Please contact us if you would like advice on modelling these situations in LinSig V3.




L3.02 How can I lock a Stage Length when optimising ?

A Stage can be locked to a fixed length by right clicking on the Stage's blue Stage Change Point handle in the Signal Timings View and choosing 'Lock Length of Stage x when Optimising'. LinSig will then optimise other stage lengths around the locked stage lengths.





LinSig Version 2 Answers


L2.01 Can I Load a LinSig V1 file ?

Yes. LinSig V2 will load in all the data included in the LinSig v1 file. However, since LinSig V2 uses a large amount of extra information, there will be some LinSig v2 specific data that will not be available in the LinSig V1 file and this will need to be added manually after loading.


At the very least, the following will need to be added:

  1. Exit Arms and Link Connectors to the Exit Arms.
  2. Add Zones that represent origins or destinations for traffic entering or leaving the network.
  3. Add a Traffic Flows matrix defining the flows from Origin Zone to Destination Zone. The Link flows imported from the LinSig V1 file can currently be found in the Link Grid Data View (on the Junction menu).

back to FAQ questions...



L2.02 One of my views keeps disappearing behind a larger View.

All the Views in LinSig V2 have an Always On Top feature that ensures that they remain visible on top of other Views. You can set any View to be Always On Top by clicking the drawing pin button in the top right-hand corner of the view.


This is especially useful for having a smaller view on top of a larger view, for example to have the Intergreen View on top of the Junction Layout View.


But beware of setting a large view to be always on top or all your other views may be hidden behind it!


back to FAQ questions...



L2.03 Why are there no routes ? I've added Links and Connectors.

The Route List View will display all the routes through your model. LinSig automatically keeps this list up to date. If there are no routes in the list, this is most likely because the appropriate Zones have not been created.


In LinSig, a Route is defined as starting at an Origin Zone and ending at a Destination Zone. In order to add Zones, select Junction ... Add Zone in the Junction Layout View, position the Zone as required and then specify which Arm is the entry Arm at that Zone and which Arm is the exit Arm at that Zone.


back to FAQ questions...



L2.04 How do I model multiple stage streams in my controller ?

LinSig now has the facility to model multiple Stage Streams. However, as many straightforward junctions only require a Single Stage Stream, LinSig defaults to Single Stage Stream mode. The mode can be switched in the controller settings at File...Settings For This File...Allow Multiple Stage Streams.


When you are in Multiple Stage Stream mode, the Stage View now displays a row of stages for each Stage Stream. Phases can be added to or removed from a Stage Stream by double-clicking on the phase in the left-hand box for that stream.


back to FAQ questions...



L2.05 Why is the Link Results View not showing any results ?

It is most likely that there is an error in the model that is preventing LinSig from being able to calculate results.


The Error View lists any errors and warnings in the LinSig model along with their location and severity. Double-click on an item in the Error View and LinSig will highlight the cause of the problem.


back to FAQ questions...



L2.06 Why are there no arrows on my newly created links ?

LinSig V2 requires that you add Link Connectors to define the movements on your links.


Link Connectors define which traffic movements are allowed between Links on different Arms. When modelling a single junction, Link Connectors simply define which Exit Arms traffic from each Link may travel to.


Link Connectors are added in the Junction Layout View by dragging with the mouse from one Link to another Link.


back to FAQ questions...



L2.07 How do you explain different results between LinSig V1 and LinSig V2 ?

For simple Links LinSig V2 should give similar capacity results as LinSig V1. The Right Turn Model has been improved to model a number of effects the Webster & Cobbe model used in V1 couldn't handle so this will lead to improved accuracy in some cases.


Delays and queuing are modelled in a completely different way in LinSig V2 than LinSig V1. Delays and queuing in V1 were again based around Webster and Cobbe and did not attempt to model variations of queues within cycles in any way and included assumptions on the randomness of arriving traffic. LinSig V2 explicitly models queue variation within a cycle and includes different assumptions of the randomness of arrivals. This is designed to tie in better with changes in assumptions in other software such as TRANSYT, not necessarily because any particular assumption is universally better or worse, but to achieve greater consistency between different models. I would therefore expect some differences (which may be quite large at short queue lengths) in queuing between the models, but generally LinSig V2 is modelling things in a more sophisticated manner and should therefore be a 'better' result. As with all queuing estimates though remember to compare like with like as there are many different definitions of 'queue'.


back to FAQ questions...



L2.08 What's happened to the 'Short Lane Only Links' option from LinSig V1?

The use of Short Lane only Links in LinSig V1 was provided only to allow some very rare specialist cases to be modelled. As some users mistakenly used Short Lane only Links inappropriately it was decided to remove the Short Lane only Links option to prevent confusion in LinSig V2. Whilst the option was available in LinSig V1 we found only a handful of cases where short lane only links were used correctly. If you feel you have a valid use for Short Lane only Links please contact us and we will consider reinstating this option if appropriate. With LinSig V2.4 and above you may find the new model for opposed short right turn lanes may be more appropriate than this option. Please contact us ((01522) 751010) if you require any further advice on this issue.


back to FAQ questions...



L2.09 I've created two scenarios, one for AM Peak and one for PM Peak. If I optimise the AM Peak Scenario and then switch to the PM Peak scenario and optimise that, when I go back to the AM Peak scenario the timings and results have changed. What am I doing wrong ?

In LinSig 2.3 and below, the Signal Plan stores both the Stage Sequence AND the timings for that stage sequence.  So, if you need to store different sets of timings then you'll need a separate signal plan for each set of timings. (You can use the "Copy Signal Plan"  function to help create multiple Signal Plans.) In this example you'll need an AM Peak Signal Plan and a PM Peak Signal Plan.  Then make sure that each scenario is using the appropriate Signal Plan, and the timings for each Scenario will be independent.  LinSig V2.4 introduces a new system of Scenarios and Staging Plans which overcomes this issue.


back to FAQ questions...



L2.10 When I select a different Flow Group in the Traffic Flows View or a different Staging Plan in the Staging Plans View the LinSig results don't change.

Some subtle changes have been made to the user-interface in how you use Flow Groups, Staging Plans and Scenarios.


In the previous version of LinSig (version 2.3), there were Flow Groups and Signal Plans. Whichever Flow Group was currently selected in the Traffic Flows View (or selected in the drop down list on the toolbar) was the Flow Group that LinSig used for calculating and displaying results. Similarly, whichever Signal Plan was currently selected in the Signal Plans View (or selected in the drop down list on the toolbar) was the Signal Plan that LinSig used for calculating and displaying results.


You could also optionally create a Scenario, defined by specifying a Flow Group and a Signal Plan. Then, when you selected the Scenario, LinSig would ensure that its Flow Group and Signal Plan were also currently selected - this simply acted as a shortcut for manually selecting the Flow Group and the Signal Plan.


In the latest version of LinSig (version 2.4) this has changed as follows.  Firstly, Scenarios are now mandatory. You still define a Scenario by specifying a Flow Group and a Staging Plan (no longer called Signal Plans).  The important thing to note is that LinSig now calculates and displays results for the currently selected Scenario.  This means that it doesn't matter which Flow Group you've selected to look at in the Traffic Flows View or which Staging Plan you've selected to look at in the Staging Plan View, LinSig will always calculate and display results using the Flow Group and Staging Plan that you've specified in the currently selected Scenario.


You can think of the Traffic Flows View as showing a menu of available Flow Groups, and the Staging Plans View as showing a menu of available Staging Plans, and from these menus you choose the appropriate ones for each Scenario that you create.


So in a typical example, you may have two Flow Groups, namely "AM Peak" and "PM Peak". You may also have two Staging Plans, say, "Sequence with Left Filter" and "Sequence Without Left Filter". You could then define four Scenarios as follows:


Scenario 1: AM Peak, "Sequence with Left Filter"

Scenario 2: PM Peak, "Sequence with Left Filter"

Scenario 3: AM Peak, "Sequence without Left Filter"

Scenario 4: PM Peak, "Sequence without Left Filter"


This has the immediate advantages over the way LinSig used to work in version 2.3.  It is easier to manage your Scenarios - no longer any need to have duplicate copies of Signal Plans for each Scenario.  Furthermore, the Scenarios View allows you to see summary results for all your Scenarios at once and gives you the ability to batch optimise some or all of your Scenarios at once.


back to FAQ questions...



L2.11 I have a file created in version 2.3 that didn't make use of Scenarios.  How will this be loaded into version 2.4 ?

LinSig 2.4 knows that a LinSig 2.3 file may or may not contain Scenarios and does its best to convert them when loading.  No information is discarded during this process, although it is possible that LinSig may create extra Scenarios for combinations of Staging Plans and Flow Groups that were not originally intended (these Scenarios can of course be manually deleted after the file has loaded).  If the LinSig 2.3 file already has Scenarios defined, they are loaded straight in.  New Scenarios are created for any Signal Plans that aren't already used in a Scenario, retaining the timings.  If there's only one Flow Group, LinSig will automatically assign that Flow Group to each new Scenario, however if there is more than one Flow Group then LinSig will leave it up to the user to assign the Flow Group in those Scenarios.


back to FAQ questions...





TranEd Version 2 Answers


T2.01 How do I find out what version of TranEd I have ?

To check the version of TranEd currently installed on your computer choose "About..." from the "Help" menu in TranEd.


back to FAQ questions...



T2.02 How do I find out exactly what version of TRANSYT I have ?

TRANSYT 10:

The TRANSYT version number is displayed at the top of a TRANSYT output '.prt' file.

TRANSYT 11 & 12:

To check the version of TRANSYT on your computer start TRANSYT outside of TranEd via the Windows 'Start' menu. Choosing 'About TRANSYT...' from the 'Help' menu will display the version of TRANSYT installed.


back to FAQ questions...



T2.03 What versions of TRANSYT will TranEd work with ?

TranEd will link with TRANSYT versions 10,11 and 12 allowing the model being developed to be run from within TranEd. A full TRANSYT licence obtained from TRL Ltd, the authors of TRANSYT, must be held for each computer on which it is used regardless of whether TranEd is being used.


back to FAQ questions...



T2.04 I have previously used the TranEd Beta and now have a Network Unlimited Licence, but when I start TranEd a message appears saying there is a Site Conflict. How do I fix this?

Remains of the TranEd Beta activation code are interfering with TranEd obtaining a licence from the Network Unlimited Licence server.  To remove any activation codes remaining from the TranEd Beta please contact us at support@jctconsultancy.co.uk for a removal tool.


back to FAQ questions...



T2.05 When attempting to load a TRANSYT file I get an error message "The file is not a valid TranEd file". How do I load TRANSYT files?

TranEd uses its own file format which is designed to include much more information than TRANSYT, such as Intergreens and text labels. Files in TRANSYT format (or TranEd Version 1) therefore need to be imported into TranEd using the 'Import TRANSYT file' option on the 'File' menu. This will import the TRANSYT data into TranEd which can then be saved as TranEd format if desired. The original TRANSYT format file is not changed in any way. Remember if you then export the file back to TRANSYT format you will lose all the additional TranEd specific information, such as intergreens, which TRANSYT does not understand. It is therefore recommended you work with the file in TranEd format whenever possible.


back to FAQ questions...



T2.06 How do I enter the inflows and cruise times/speeds on links ?

In TRANSYT speeds/times are defined on the connections between links rather than the links themselves. First you must define the connections between the links. To do so, first select "Link Connector Mode" from the View menu.  When in link connector mode the cursor in the Network Layout View will become a cross-hair.  You can now connect up your links by clicking on the end of one link and dragging to the start of another link. Each time you do this you create a new Link Connector.

Having created link connectors, you can select each connector and enter its inflow and cruise time/speed in the Item Edit Area located to the left of the Network Layout View.


back to FAQ questions...



T2.07 How do I move a link from one node to another ?

Any link can be moved from one node to another, provided that it is a non-signalled link (Bottleneck, Priority, or Priority Bottleneck). This is done by first selecting the link.  Then in the Item Edit Area, select the Link tab, and where the Controlling Node for that link is displayed there will be a "Change..." button. Click the "Change..." button to move the link to a different node.


 If the link you wish to move is signalled (Signal Controlled or Signal and Priority Controlled), you must first change the link type to be non-signalled (Bottleneck or Priority Bottleneck, respectively). This is because signal data valid for a link on one node is unlikely to be valid when the link is moved to a different node.


back to FAQ questions...



T2.08 After running TRANSYT from within TranEd the message "An Error occurred updating the network from the TRANSYT run results" is displayed. What could have caused this ?

This error indicates that TranEd has validated a TRANSYT run and is happy with it but TRANSYT has not run correctly for some reason. For example this error would occur if TRANSYT crashed for any reason.

One possible cause of this error occurs if a stage runs with a TranEd calculated minimum of zero seconds. TRANSYT sometimes (but not always) incorrectly outputs invalid green splits that either are not in sequence, or violate the minimums of other stages on the node.  In this scenario, TranEd will not be able to correctly interpret these stage timings and will display "An Error occurred updating the network from the TRANSYT run results".


You can check if this is indeed the case by viewing the TRANSYT output (.PRT) file (TranEd menu option TRANSYT->Show PRT Viewer), and verifying whether the stage timings that TRANSYT has generated are valid or not.


A workaround (provided that it is valid to do so for your particular network being modelled) is to force the calculated stage minimum to have a false minimum of 1 second by setting the Stage Minimum to 1 in the Stage View. Provided the actual optimised duration of the stage is longer than the minimum this should not affect the results.


We believe this TRANSYT error has been fixed in TRANSYT Version 11/AJ and later.


back to FAQ questions...



T2.09 After running TRANSYT from within TranEd the message "[filename.prt] was not found" is displayed. What could have caused this?

One common cause of this error is running TRANSYT 11 Versions AI, AH or AJ with Windows XP Service Pack 2. This is a TRANSYT compatibility issue with Windows XP which can be resolved by obtaining TRANSYT 11 Version AK from TRL Ltd.


Other causes are possible usually due to incorrect set up of the link between TRANSYT and TranEd. It is recommended that the link between TRANSYT and TranEd is checked in the 'Program Options' dialog box. If this does not resolve the problem please contact JCT Consultancy Software Support.


back to FAQ questions...



T2.10 How to I keep a view always visible on the screen without it being hidden behind my other views?

Each view in TranEd has a pushpin icon in the top right hand corner. When the pushpin is pressed, the view will remain on top of the other views, even when it is not the active view. This can be used, for example, to allow you to have smaller views such as the Link Intergreen View and the Error View always visible while you work in the Network Layout View.


back to FAQ questions...



T2.11 How do I add Link Delays to my links ?

Link delays can be specified by selecting the relevant node and then selecting the Link Delays page in the Item Edit Area on the left.


back to FAQ questions...



T2.12 When I try to run my file through TRANSYT I get the error message "WARNING SECURITY FAILED". What does this mean?

The later releases of TRANSYT 11 (release AK) and TRANSYT 12 (releases AC/3 and above) include some additional security checks to ensure that TRANSYT is correctly licensed. This relies on having started the TRANSYT 12 graphical interface.


This means that you need to ensure that the TRANSYT 12 graphical interface is open at the same time as using TranEd 2. Note that once the TRANSYT 12 graphical interface has been opened, it can then be minimised and no further interaction is required to continue using TranEd 2. No files need to be opened within the TRANSYT 12 graphical interface.


You can start the TRANSYT 12 graphical interface from the Windows Start Menu at :


Start -> Programs -> Transyt 12 -> Transyt 12


back to FAQ questions...



T2.13 After running TRANSYT from within TranEd the message "This application has failed to start because ERIS.dll was not found. Re-installing the application may fix this problem" is displayed, followed by "[filename.prt] was not found". What has caused this?

This can occur if you are using TRANSYT 12.1 AF/6. This version of TRANSYT is only compatible with TranEd version 2.4.3.0 or above. Updating your version of TranEd to version 2.4.3.0 or above will solve the problem.


back to FAQ questions...





FlowRound Answers


F.01 How do I find out what version of FlowRound I have ?

To check the version of FlowRound installed on your computer choose "About..." from the "Help" menu in FlowRound.


back to FAQ questions...



F.02 I have previously used the FlowRound Beta and now have a Network Unlimited Licence, but when I start FlowRound a message appears saying there is a Site Conflict. How do I fix this?

Remains of the FlowRound Beta activation code are interfering with FlowRound obtaining a licence from the Network Unlimited Licence server.  To remove any activation codes remaining from the FlowRound Beta please contact us at support@jctconsultancy.co.uk for a removal tool.


back to FAQ questions...





























































 

Site search



 
 

Upcoming courses

22 Jan 2019: Introduction to Traffic Signals ...more

24 Jan 2019: LinSig3 : Junction Modelling Computer Workshop ...more

11 Feb 2019: LinSig3.2 : SCATS Modelling Workshop Australia and New Zealand ...more

13 Feb 2019: LinSig3 Signalled Roundabout Design ...more

14 Feb 2019: LinSig3.2 : SCATS Modelling Workshop Australia and New Zealand ...more

...view full schedule

...view course descriptions

 
 

Subscribe to email updates

To subscribe to Course, Software or Symposium update emails, please click here